WordPress выпустил обновление с исправлением ошибок, версия 5.6.2. Помимо проблемы, затрагивающей плагин Ultimate Addons for Gutenberg, обновление в значительной степени прошло успешно, издателям рекомендуется обновить его.

WordPress 5.6.2

WP 5.6.2 называется Техническим обновлением. Техническое обновление – это обновление, предназначенное для исправления ошибок, появившихся в предыдущем обновлении. Поскольку техническое обновление устраняет проблемы, издателям обычно рекомендуется обновить свои WordPress до последней версии.

Исправление ошибок

Последнее обновление устраняет проблему, возникшую в версии 5.6.1. Этот вопрос назывался « Покинуть сайт? Внесенные вами изменения могут не сохраниться ». Что происходит, так это то, что на определенных страницах в бэкэнде администратора WordPress выдает предупреждение о том, что внесенные изменения не будут сохранены.

Первоначальный отчет об ошибке описывал это так :

«Мы широко используем пользовательские таксономии, и с сегодняшнего дня 5.6.1 на каждой странице пользовательской таксономии появляется запрос« Покинуть сайт? Внесенные вами изменения не могут быть сохранены ». Этого никогда не случалось с пользовательскими таксономиями, и теперь это быстро становится действительно надоедливым ».

Это вызвало значительную путаницу в сообществе издателей WordPress, поскольку многие не понимали, почему они получили предупреждение.

Издателям WordPress рекомендуется выполнить обновление до версии 5.6.2, поскольку она содержит исправление ошибок и нет широко распространенных сообщений о проблемах.

Ultimate Addons для ошибки Gutenberg

Единственная обнаруженная ошибка связана со сторонним плагином Ultimate Addons for Gutenberg от Brainstorm Force.

Согласно отчету на форумах поддержки WordPress, ошибка вызывает проблемы с отображением. Что касается ошибок, это относительно небольшая проблема. Проблема, по-видимому, связана с плагином, а не с WordPress.

Издателям, использующим плагин Ultimate Addons for Gutenberg, у которых возникают аномалии отображения, рекомендуется подать заявку в службу поддержки в WP Astra , издателя плагина.

Человек, сообщивший о проблеме, поделился таким описанием проблемы:

«Я провел некоторое тестирование и смог определить проблему. Это плагин, в частности Ultimate Addons для Gutenberg. А точнее, это происходит только при использовании пост-карусели.

Примечание. У проблемы может быть больше триггеров, но это тот, на котором я сейчас сталкиваюсь.

Когда я отключу этот плагин, проблема исчезнет. К сожалению, я не могу просто отключить его, потому что я использую некоторые из этих блоков для большого количества контента.

PD: О, и если вам все еще нужна информация, я использую тему Astra.

ПД2: Я попробовал темы twenty twenty-one и twenty nineteen, и проблемы нет. Кажется, это связано с совместной работой Astra и Ultimate Addons for Gutenberg ».

Ошибка кажется довольно несущественной проблемой, которая затрагивает относительно небольшое количество издателей WordPress.

WordPress 5.6.2 кажется безопасным обновлением. Издателям рекомендуется обновить свои установки WordPress.

Добавить комментарий

Ваш электронный адрес не будет опубликован. Обязательные для заполнения поля помечены *

Оставить комментарий